
Mapping Section data with MAPaint

The data associated with this example is as follows:

This is a section from Ruth Arkell, MRC Mammalian Genetics Unit, Harwell.  An
antisense digoxigenin labelled mRNA probe for AP2 (Mouse gene nomenclature
committee approved symbol:Tcfap2a) was used on a wholemount and subsequently
sectioned.  The probe was transcribed from the entire insert of the RIKEN clone
2810443O20 which is an EST tagged clone (Genbank Accession number for the 5'
EST sequence read is BY712305). Clone 2810443O20 was originally isolated from a
C57BL/6J pooled 10+11 day embryo whole body cDNA library. The specimen used in
the current study was a 9.0dpc CD1 mouse embryo.  The visualisation method used in
this experiment was Alkaline Phosphatase with NBT and BCIP and expression has
been described in this case as being in the neural crest derived mesenchymal
component of the head and specifically, the 1st branchial arch.

Original image:

AP2.jpg

This AP2.jpg file was saved into your home directory for the purposes of this course.
To view this image, use the normal image viewing program available on your operating
system (eg. preview, image magick, photoshop etc).

What Theiler stage is this sample?__________________________________________

Look at the EMAP mouse embryo staging criteria pages for help
(http://genex.mrc.ac.uk/Databases/Anatomy/MAStaging.shtml)

 In an Xterm window, go to your home directory

% cd

 Then make a directory for the source image and give it the name
"section".

% mkdir section



 Move the original image file (in jpg or tiff format) from your home
directory (where it has been copied before the course) into this new
directory.

% mv AP2.jpg section

 Change to the new directory that you have made (ie. "section").

% cd section

 To check the AP2.jpg file is in this directory, you can list its contents
by typing

% ls

 Open the version of MAPaint required for spatially mapping data for
EMAGE by typing on the command line…

% MAPaint_EMAGE &

Since you started MAPaint in this directory ("section"), whenever you
now save files during this session of MAPaint, they will all be saved
into this "section" directory.

A window called "MAPaint_EMAGE" will open:

 Select from the "File" menu, "Open EMAP Model".  The 2D and 3D
'EMAP Model' image files of the standard embryos are on the CD.  In
your home laboratory you can copy these to your hard drive.  If reading
from the CD, make sure the CD-ROM is inserted, and navigate to it from
within the MAPaint program (on MacOSX the CD is found in the
Volumes folder; on Linux it depends where the CD has been mounted - it
should usually be found at /mnt/cdrom; on Solaris is will be found at
cdrom/dcrom0). To go up a directory at any stage, double click on ".."

On the CD there is a directory called "Models".   Navigate to this
directory.  It contains a sub-directory for each of the EMAP models
(these are denoted by Theiler stage) and within each Theiler stage



directory is a 3D file of that particular embryo model (embryo_1_3D) as
well as left and right 2D whole mount views of the same model
(embryo_1_WM_left and embryo_1_WM_right).

The AP2 image is a section through the head of a TS13 embryo and as opposed to
simply choosing the left or right side views of the whole embryo in the wholemount
case, this time a matching section must first be selected from within the 3D embryo
model before the data can be warped and thresholded.

 Navigate to the ts13 folder and open it by double clicking on it.
Inside is a 3D embryo model file called embryo_1_3D.  Open this
file by double clicking on it. The white box in the MAPaint window
will change to one with red, green and blue sides.  This box
represents the space that the embryo model resides in.

 Select all of the following from the "View" menu: "X-Y view ...", "Y-Z
view ..." and "Z-X view ...".  Three windows with sectioned views of
the embryo model in the three standard axes will open.

        



If needed, resize the individual images using the "mag+" and "mag-" buttons. When
the cursor is positioned within one of these windows, the plane of the section shown in
that window is also depicted in the other two windows by the light blue lines.  The
position of the section plane along each axis is controlled using the 'distance' slider.
The default distance is set to 0. Move the distance slider and the plane will move
accordingly in the box in the MAPaint window.

To see which direction the section plane is being viewed from (it can be viewed from
either side depending on the settings), click on the "view direction" option at the top of
the relevant window. An arrow appears in the MAPaint window showing the direction
of view. Click on "view direction" again to remove the arrow.  Select "Mask" from the
"3D feedback" drop down menu to display a representation of the currently shown
section in the 3D space.

    

 In any of the 'Section view' windows, click on the box beside
"controls" and the frame will expand to show extra controls including
"pitch" and "yaw". Using distance in conjunction with pitch and yaw
in the three views, find a target section that corresponds to the input
AP2 data section:



Instead of simply using pitch and yaw, you may find it easiest to rotate the 3D embryo
model around a line within the 3D space to find the desired section. Do this by
selecting "point define" from the "fixed line" menu using the right hand mouse button.
A cursor (as a very small black dot) will appear.  Click once on the section image using
the left hand mouse button to define the start of the line and then position the cursor at
the end of the line and click again using the left hand mouse button.  The "pitch" and
"yaw" options beneath the image will be replaced by "line rotation".  Use the slider to
rotate the 3D object around the selected line.  The section view will change in the
section window and the plane will move accordingly in the box within the MAPaint
window.  To deselect the line rotation option, move the distance control.

  When happy with your choice of section, write a ".bib" (bibliography)
file to record the section you have chosen by clicking on the "I/O"
button using the right hand mouse button and selecting "write" from
the list that appears.  In the "Get Filename Dialog" window that
appears, change the default file name MAPaintSectParams.bib
to AP2.ts13.1.bib, click on "OK" and then close the "Section
View" window.  This can be used to read in this section again later.

The standardised way for writing bib files for section data in MAPaint for later inclusion
in the EMAGE database is filename.ts##.X.bib where ts and the two following
numbers ## refer to the Theiler stage of the model you are mapping onto,  X refers to
the number of the embryo model (e.g. for TS15  and TS16 there is more than one
embryo model).
bib files must be saved using this standardised nomenclature in MAPaint
otherwise it will not be possible to enter this data into the EMAGE database later
on.

 Now close all "section view" windows you have open.



  Having chosen the target section, now commence the warping
procedure to place the data from the input section onto the standard
section you have chosen by going back to the MAPaint window and
selecting the "Options" menu and then "2D warp input".  A 2D warp
input dialog window will open:

 Click on the square beside "Controls" to expand the window and
with the right hand mouse button, click on "I/O" and select "Read"
from the list. A "Get Filename Dialog" window opens.  Click on
"Browse" to show a new window displaying your previously saved
AP2.ts13.1.bib file.  Select this file by double clicking on it and
then click on "OK" in the next "Get Filename Dialog" box that
appears.  The file is read and the corresponding section displayed in
the window.



 Click on the "controls" box again to minimise the window.

 Now click on the "2D warp input controls" box to open a new
"warp2DinteractDialog_popup" window which contains three panels,
the left hand one of which will contain the target section you have
chosen.

 Back in the "2D warp input dialog" window click on the
"ReadSource" button to open a "Read Warp Input Source Object"
window. Select AP2.jpg from the list by double clicking on it. (For
source images other than jpg’s, select the appropriate file type from
the drop down “image type” menu).  This image is loaded into the
middle panel of the "warp2DinteractDialog" window.



The left hand panel contains the target section within the model.  The middle panel
contains the input image file and the right hand panel contains an overlay of both of
these files. To get the images into the fields of view, either magnify (click on "mag+"
button) or reduce (click on "mag-" button) or rotate (click on "rot") each separately. To
adjust the contrast of the images in each panel, click on the up and down arrows. To
change the two colours in the overlay panel, click on this panel using the right hand
mouse button, select "overlay method" and then select a colour combination that you
like (red-cyan gives good contrast).

 Start entering tie-points between the selected section within the
target section (left hand panel) and the input data (middle panel). To
add a tie point, move the cursor to an appropriate place on the
selected section on the left and click with the left hand mouse button
(a red dot appears), then move the cursor to the equivalent point on
the input image file and click with the left hand mouse button (both
dots will change to green). Moving the cursor back over the dot will
change the colour of the two linked dots to red and can be used to
determine which dots are linked to each other in the two panels and
can be used to adjust their position independently of each other by
clicking on and dragging one of the points. To remove two linked
points, move the cursor over either and use the middle mouse button
to remove both.

Initially enter 4-8 tie-points around the area you are mapping at easily recognisable
positions.  This ensures both images are of similar size and helps in subsequent tie-
point mapping. Enter more tie-points at easily recognisable landmarks paying particular
attention to regions of gene expression. Typically around 30-50 tie points may be
required to adequately warp the expression pattern.



This process works by warping an underlying triangular mesh across the two images.
For every triangle in the left hand image there is an equivalent triangle in the central
image.  You can see the underlying mesh by right clicking on the left hand and middle
panels and selecting the “show mesh” option.

If you try to enter a point that generates an invalid mesh (eg. when the mesh has to
'fold' back over itself - in these cases the problem part of the mesh will be seen in a
different colour to the rest of the mesh), an error message will appear in a window
entitled "confirm dialog" giving the options of 'select yes to attempt to correct the mesh
automatically or no if you want to move some of the tie points or reset the mesh
parameters and try again".

Initially it is a good idea to select "no", remove the inappropriate tie-point using the
middle mouse button and try again.  If you still have a problem, zoom in to help when
adding tie points.  Depending on the original data, another way to help in getting the
mesh to tolerate the warping required may be to adjust the "Mesh min distance" and
"Mesh max distance" parameters in the "2D Warp Input" window.  These are the
minimum and maximum distances that the sides of the triangles will stretch/contract to
during the warping.

 Write a ".bib" file to record the tie-points you have entered by clicking
on the "I/O" button under the left hand panel while using the right
hand mouse button and then selecting "write warp data" from the list
that appears. A window will appear entitled "Get Filename Dialog"
with the default file name of "MAPaintWarpParams.bib"

  Change the name to AP2.bib and click on the "OK" button.



Now regions will be denoted on the section representing different areas of AP2 expression
(or non-expression) using a thresholding method.  The program allows for regions of strong,
moderate, weak and possible expression to be denoted as well as regions that have no
detectable expression and areas that have not been examined.  Not all of these may be
required.  Bear in mind not to over-interpret the data (ie. adding strong, weak and moderate
levels of gene expression may not be any more meaningful than adding two regions).  In the
case of this example, denoting regions of strong and moderate expression is enough (along
with regions that have no expression detected and regions that have not been examined).

 Get ready to read in the colour image for thresholding by going back
to the "2D warp input dialog" window and clicking on "Import>>". A
new panel will appear on the right hand side of the window.

 Click on the "read" button above the new panel and a window entitled
"read signal object" will open. Select the AP2.jpg source image and
click on "OK".  (For source images other than jpg’s, select the
appropriate file type from the drop down “image type” menu).  The
image file will then appear in the right hand panel of the 2D warp
input dialog window. To fit the image in the panel, either magnify
(using "mag+" button) or reduce the image (using the 'mag-' button)
as required.



 Look at the colour image of AP2 to discern the region of highest
signal intensity and then go to the "2D warp input dialog" window.
Select the “Threshold” tab in the “Signal processing” panel, and then
select the “Interact” tab on the right.  Click once with the left hand
mouse button on the region of the data image with the strongest
signal.  Continue to hold the button down while dragging the cursor to
an appropriate region on the image that denotes the lower limit of
strong gene expression.  Then release the mouse button to define
the lower limit of strong gene expression.  Don't worry at this stage if
you also incorporate some yellow areas corresponding to other areas
such as debris as these will be removed later.  If the region selected
is not appropriate, click on "reset defaults" and try again.



Note: it may sometimes be easier to extract signal by using other strategies apart from
the "interact" method.  For example the "single" option sometimes works better to
extract either the overall image density (ie. in grey mode) or just the blue, red or green
colour channel (while in RGB mode) or the cyan, magenta or yellow colour channel
(while in CMY mode).  Try some different methods in this AP2 example to see how
these signal extraction methods differ.

 Click on the "map the data" button under the right hand panel and the
data will be transferred onto the target section in the left hand panel
in red:

 If you are satisfied with the positioning of the transferred data,
proceed to the next step. If it is not satisfactory, click on the "undo
mapped data" button and re-adjust the tie points in the
"warp2DinteractDialog" window and then re-save the bib file
Ap2.bib to record the re-adjusted position of the points.

 Write another "bib" file that contains information on the thresholding
levels for the regions of strong gene expression by clicking with the
right hand mouse button on the "I/O" button under the left hand panel
and selecting "write warp data" from the list that appears. As before,
a window will appear entitled "Get Filename Dialog" with the default
file name M A P a i n t W a r p P a r a m s . b i b . Change to
AP2.strong.bib and then click on the "OK" button.

 Remove any red areas of debris that have been carried across with
the thresholding by going to the MAPaint window.  The program is
set by default to 'paintball' mode with the cursor appearing as a black
dot.  Use the middle mouse button to remove any areas of debris.
This may not be required. If you make a mistake, click on "undo".

The size of the paintball can be adjusted by selecting "tool controls" from the "options"
menu and then changing the Paint size with the slider.  The painting mode can also be
changed to other formats (draw, fill, threshold, affine etc) by selecting these from the



"Paint tools (2D)" menu within the "options" menu.  The behaviour of all of these tools
is such that using the left hand mouse button generally is used to add colour whilst
using the middle hand mouse button is used to remove colour.

 Now add any red areas that you feel represent true expression and
have been missed by the thresholding technique by using the
paintball with the left hand mouse button.  It may be necessary to
adjust the "Paint size".  Once again, If you make a mistake, click on
'undo' using the left hand mouse button.

When happy with the areas representing strong expression, the process is now
repeated for areas of moderate (yellow), weak (blue), possible (green) expression as
well as areas with no detectable expression.  The process used is exactly the same for
each however the domain has to be selected separately for each. Remember that not
all of these levels may be required.

 Select the moderate domain by choosing the "Domain" menu and
then the "Select" menu and finally "Moderate Expression".  The
border surrounding the embryo model on the left will change from red
to yellow.  Repeat the thresholding procedure so that the yellow
areas in the right hand panel now adequately cover sites of moderate
gene expression.  This can be done either by starting the
thresholding procedure again, and extending to include moderate
areas of expression, but is most easily achieved simply by moving
the threshold distance slider up which automatically extends the
range of the selected expression intensity. Again, don't worry at this
stage if you also include some yellow areas corresponding to other
areas such as debris as these will be removed later.

Click on the "map the data" button under the right hand panel and the
data will be transferred onto the standard model in the left hand
panel in yellow:

 Write a new "bib" file that contains information on the thresholding
levels for the regions of moderate gene expression by clicking with
the right hand mouse button on the "I/O" button under the left hand



panel and selecting "write warp data" from the list that appears. As
before, a window will appear entitled "Get Filename Dialog" with the
default fi le name MAPaintWarpParams.bib. Change to
AP2.moderate.bib and then click on the "OK" button.

Remove any yellow areas of debris that have been carried across
with the thresholding by going to the MAPaint window and selecting
the "Options" menu and then the "Paint Tools (2D)" and "Draw".
Back in the "2D warp input dialog" window use the middle mouse
button to circle all yellow areas that represent debris and then click
the right hand mouse button to remove the areas of yellow within the
line. Again, this may not be required. If you make a mistake, click on
the "undo" button using the left hand mouse button.

Add any yellow areas of moderate expression that you feel have
been missed by the thresholding by going to the MAPaint window
and selecting the "Options" menu and then the "Paint Tools (2D)"
and "Paint Ball". In the "2D warp input dialog" window use the left
hand mouse button to paint in any yellow areas that represent true
expression that have been missed by the thresholding technique. If
you make a mistake, click on "undo" using the left hand mouse
button.

Continue on as before thresholding, painting and saving the .bib file for each level of
expression detected in the original image.

  Denote areas in the target section with no detectable expression by
firstly selecting the "Domain" menu and then the "Select" menu and
"Not Detected" and then the "Options" menu, "Paint Tools 2D" and
then "Draw".  In the "2D warp input dialog" window use the left hand
mouse button to circle regions that you are examining which have no
detectable expression (in this case it is the rest of the head) and then
click once on the right hand mouse button. The area within the line
becomes cyan and represents areas of non-detectable gene
expression within regions of the section that you are mapping.



 Denote all of the areas of the section that have not been examined
by firstly selecting from the "Domain" menu, "Select" and then "Not
Examined".  Then select from the "Options" menu, "Paint Tools (2D)"
and then "Fill".  In the "2D warp input dialog" window click once with
the left hand mouse button on part of the section that you have not
mapped data to. The area outside the region you have already
mapped data to become brown. This represents areas of the section
that have not been examined in your experiment.  If required, make
any fine adjustments using the "paint' tool.  (eg in this case, the distal
tips of the branchial arches, the tail and extra-embryonic membranes
are regions that have not been examined - see below).

 Save the files for the regions of different expression levels by firstly
clicking on the "2D warp input controls" box. The border surrounding
the image of the target section in the "2D warp input dialog" window
changes to black signifying the files are ready to be written.



 In the MAPaint Window select from the "Domain" menu, "Save All
Domains". This automatically saves the files in "woolz" format (.wlz)
to your working directory (i.e. the directory you were in when you
started MAPaint) for whichever domains you have created as:
strong.wlz; moderate.wlz;  weak.wlz; possible.wlz;
notDetected.wlz and notExamined.wlz

 Quit the MAPaint program. A window appears entitled "confirm
dialog" with the message "really quit? " Click on "yes". Another
"confirm dialog" window appears with the message "really really quit?
" Click on "yes" and the program quits.

 Check that you have the relevant files that will be required to load
this entry into the EMAGE interface later.

These are:

 the original image file AP2.jpg,
 the bib file to tell the EMAGE interface which section to use

when visualising the mapped expression and will in this case
be AP2.ts13.1.bib.

 the appropriate .wlz files that denote the different regions of
expression you denoted: strong.wlz; moderate.wlz;
notDetected.wlz and notExamined.wlz

All section data can be spatially mapped using the same process apart from radio-
active in situ data that has been imaged using separate bright and dark-field images.
In this case it is usually necessary to extract signal from the dark-field image which
often cannot be used for the warping procedure due to a lack of morphological
features.  In these cases the bright-field image can be read in as the source object for



tie-point placement and warping whilst the dark-field image can be read in separately
as the source image for signal thresholding.  This process requires however that the
two images are of exactly the same size and magnification.

For example these two images of Msx2 have been digitised without moving the slide
and are suitable for use in this manner:

     Msx2.bf.jpg   Msx.df.jpg


